"Custom Client" via app_info.xml


Advanced search

Message boards : Client : "Custom Client" via app_info.xml

Author Message
overkill
Send message
Joined: 12 Jun 08
Posts: 56
Credit: 922,628
RAC: 0
Message 12196 - Posted: 2 Jan 2014, 22:36:45 UTC

Short question...
Does burp need to allow custom clients (i.e. "Anonymous Platform") on the server end?

Long details...
I've been trying to setup an app_info.xml file to use a modified Burp client because my libraries don't exist in the current client. See this thread for history.

I'm not really doing anything other than removing the blender_ld so my local libraries get used instead of the ones delivered with the client.

I've created this app_info.xml file...

<app_info> <app> <name>blender</name> </app> <file_info> <name>blender_4.78_x86_64-pc-linux-gnu</name> <executable/> </file_info> <file_info> <file_name>blender_4.78_x86_64-pc-linux-gnu.zip</file_name> </file_info> <file_info> <file_name>infozip_license</file_name> </file_info> <file_info> <file_name>linux_zip_x64_r600</file_name> </file_info> <file_info> <file_name>linux_unzip_x64_r600</file_name> </file_info> <app_version> <app_name>blender</app_name> <version_num>478</version_num> <file_ref> <file_name>blender_4.78_x86_64-pc-linux-gnu</file_name> <main_program/> </file_ref> <file_ref> <file_name>blender_4.78_x86_64-pc-linux-gnu.zip</file_name> </file_ref> <file_ref> <file_name>infozip_license</file_name> </file_ref> <file_ref> <file_name>linux_zip_x64_r600</file_name> </file_ref> <file_ref> <file_name>linux_unzip_x64_r600</file_name> </file_ref> </app_version> </app_info>


Pretty basic. I'm haven't even changed any files yet, I just wanted to see if I could use the same client (locally) with burp. Once this step is complete, I'll continue with messing with the (local) client.

But I keep getting messages in the boinc client saying...

"BURP : Not requesting tasks: don't need"

I think this is code for.. "I'm not asking for work because your client is messed up". When I look at the project properties for burp, I see...

"Don't fetch tasks for CPU : Project has no apps for CPU"

I don't think this is related to there not being any work available. If I reset to the normal client. It tries to request work. I'm guessing this means burp is refusing to send me work because I'm not using the official client. So I'm perpetually in "No new tasks" mode.

Does the server have to allow for custom clients / anonymous platform?

Profile Janus
Volunteer moderator
Project administrator
Avatar
Send message
Joined: 16 Jun 04
Posts: 4478
Credit: 2,094,806
RAC: 0
Message 12205 - Posted: 4 Jan 2014, 14:54:00 UTC - in response to Message 12196.
Last modified: 4 Jan 2014, 14:56:03 UTC

It probably just means that the app_info.xml was malformed somehow and it didn't parse out any useful applications from it (if it did it will tell you in the logs which ones it found).

We do allow people to use the anonymous platform but no official info is provided on the site on how to do it - it is mostly left as an exercise for the reader.

From a quick look on your file I can tell that you are at least missing several important parts making some of the files executable etc.
Have a look at http://burp.renderfarming.net/forum_thread.php?id=2127&nowrap=true#11864 and earlier posts for some examples.

overkill
Send message
Joined: 12 Jun 08
Posts: 56
Credit: 922,628
RAC: 0
Message 12225 - Posted: 6 Jan 2014, 20:47:01 UTC

Well, I'm pretty stumped. Been piecing together different things from the boinc forums, client_state.xml, and the posts you recommended. Thought it could have been a platform issue, but adding the following didn't seem to make a difference.

<platform>x86_64-pc-linux-gnu</platform>
<plan_class>mt</plan_class>
<avg_ncpus>8</avg_ncpus>
<max_ncpus>8</max_ncpus>
<flops>3244797761.632886</flops>
<api_version>7.1.0</api_version>

I don't get much in the boinc logs. Just the usual "Found app_info.xml; using anonymous platform". It occasionally deletes some of my client files (even though they're in the app_info file). And always logs the "Not requesting tasks: don't need" when attempting to request tasks.

I guess I'll try again when I have more time. Or maybe with a different version of boinc (currently 7.2.33).

overkill
Send message
Joined: 12 Jun 08
Posts: 56
Credit: 922,628
RAC: 0
Message 12226 - Posted: 7 Jan 2014, 3:06:54 UTC

Starting over. I deleted the project, reinstalled boinc, and re-added boinc+burp. Then re-installed my app_info.xml Now things seems to be working.

This is the current version of my app_info.xml...

<app_info>
<app>
<name>blender</name>
</app>

<file_info>
<name>blender_4.78_x86_64-pc-linux-gnu</name>
<executable/>
</file_info>
<file_info>
<name>infozip_license</name>
<executable/>
</file_info>
<file_info>
<name>linux_zip_x64_r600</name>
<executable/>
</file_info>
<file_info>
<name>linux_unzip_x64_r600</name>
<executable/>
</file_info>
<file_info>
<name>blender_4.78_x86_64-pc-linux-gnu.zip</name>
</file_info>

<app_version>
<app_name>blender</app_name>
<version_num>478</version_num>
<api_version>7.1.0</api_version>
<plan_class>mt</plan_class>
<flops>1933209103.303349</flops>
<avg_ncpus>1.000000</avg_ncpus>
<max_ncpus>1.000000</max_ncpus>
<file_ref>
<file_name>blender_4.78_x86_64-pc-linux-gnu</file_name>
<main_program/>
</file_ref>
<file_ref>
<file_name>infozip_license</file_name>
<open_name>infozip_license</open_name>
</file_ref>
<file_ref>
<file_name>linux_zip_x64_r600</file_name>
<open_name>linux_zip_x64_r600</open_name>
</file_ref>
<file_ref>
<file_name>linux_unzip_x64_r600</file_name>
<open_name>linux_unzip_x64_r600</open_name>
</file_ref>
<file_ref>
<file_name>blender_4.78_x86_64-pc-linux-gnu.zip</file_name>
<open_name>blender_4.78_x86_64-pc-linux-gnu.zip</open_name>
</file_ref>
</app_version>
</app_info>

I have removed blender_ld from the zip file, and appear to be crunching workunits again.

Hope it keeps up.

Profile DoctorNow
Project donor
Avatar
Send message
Joined: 11 Apr 05
Posts: 392
Credit: 2,168,338
RAC: 34
Message 12228 - Posted: 7 Jan 2014, 13:04:06 UTC - in response to Message 12226.
Last modified: 7 Jan 2014, 13:04:30 UTC

Fine when it works.
Personally I don't think that the following lines are necessary in the xml but when it runs you better let it like it is. ;-)


<api_version>7.1.0</api_version>
<plan_class>mt</plan_class>
<flops>1933209103.303349</flops>
<avg_ncpus>1.000000</avg_ncpus>
<max_ncpus>1.000000</max_ncpus>

Blender isn't multithreading anyway at the moment so the plan_class is not needed.
____________
Life is Science, and Science rules. To the universe and beyond
Proud member of BOINC@Heidelberg
My BOINC-Stats


Post to thread

Message boards : Client : "Custom Client" via app_info.xml