CATS java requirements

Message boards : Client : CATS java requirements
Message board moderation

To post messages, you must log in.

AuthorMessage
mip2

Send message
Joined: 12 Jan 07
Posts: 26
Credit: 25,862
RAC: 0
Message 6641 - Posted: 7 Sep 2007, 8:50:23 UTC

Hello cats fan´s, i have a problem to use cats
with opensuse linux 10.0 with java jre 1.4.2
failure message is:

Exception in thread \"main\" java.lang.UnsupportedClassVersionError: cats/Main (Unsupported major.minor version 50.0)

Is this a version conflict?
What version of java is needed.

thank´s for any help


ID: 6641 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Janus
Volunteer moderator
Project administrator
Avatar

Send message
Joined: 16 Jun 04
Posts: 4574
Credit: 2,100,463
RAC: 8
Message 6647 - Posted: 9 Sep 2007, 19:49:28 UTC

CATS makes use of some of the new Java features (like generics) and requires at least version 1.5.x of Java to work properly.
I think it is possible to \"uglify\" the code, recompile for older versions and then run it - but I wouldn\'t recommend it.
ID: 6647 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
mip2

Send message
Joined: 12 Jan 07
Posts: 26
Credit: 25,862
RAC: 0
Message 6648 - Posted: 10 Sep 2007, 7:10:53 UTC

THX Janus

Greets mib
ID: 6648 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote

Message boards : Client : CATS java requirements