Gandalf the White Returns

Message boards : Server backend and mirrors : Gandalf the White Returns
Message board moderation

To post messages, you must log in.

1 · 2 · Next

AuthorMessage
Andrew Admire

Send message
Joined: 23 Mar 05
Posts: 108
Credit: 94,266
RAC: 0
Message 7389 - Posted: 8 Jan 2008, 15:42:25 UTC

I have a new ISP and ALOT more bandwidth. How can I reactivate my Mirror?
When life is to big to tackle, kick it in the shins.
ID: 7389 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Janus
Volunteer moderator
Project administrator
Avatar

Send message
Joined: 16 Jun 04
Posts: 4574
Credit: 2,100,463
RAC: 8
Message 7390 - Posted: 8 Jan 2008, 16:30:27 UTC - in response to Message 7389.  

I have a new ISP and ALOT more bandwidth. How can I reactivate my Mirror?

It is currently not residing on the old location - at least http://renderingproject.com/burp_mirror/mirror.php gives a 404.
So I guess you are better off re-installing the mirror through the setup guide - unless of course you have all the old data, keys, etc. stored somewhere? - then there wouldn\'t be any need for retransmitting it.
ID: 7390 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Andrew Admire

Send message
Joined: 23 Mar 05
Posts: 108
Credit: 94,266
RAC: 0
Message 7481 - Posted: 15 Jan 2008, 14:11:29 UTC - in response to Message 7390.  

I have a new ISP and ALOT more bandwidth. How can I reactivate my Mirror?

It is currently not residing on the old location - at least http://renderingproject.com/burp_mirror/mirror.php gives a 404.
So I guess you are better off re-installing the mirror through the setup guide - unless of course you have all the old data, keys, etc. stored somewhere? - then there wouldn\'t be any need for retransmitting it.


I uploaded all of the old data. Please check to see what I\'m missing.

Thanks,
When life is to big to tackle, kick it in the shins.
ID: 7481 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Janus
Volunteer moderator
Project administrator
Avatar

Send message
Joined: 16 Jun 04
Posts: 4574
Credit: 2,100,463
RAC: 8
Message 7538 - Posted: 21 Jan 2008, 22:29:51 UTC

Hm, the server returns \"\".
Perhaps we should just start the mirror from scratch using the guide?
ID: 7538 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Andrew Admire

Send message
Joined: 23 Mar 05
Posts: 108
Credit: 94,266
RAC: 0
Message 7550 - Posted: 22 Jan 2008, 14:17:12 UTC - in response to Message 7538.  

Hm, the server returns \"<!-- SHTML Wrapper - 500 Server Error -->\".
Perhaps we should just start the mirror from scratch using the guide?



That\'s fine, I will start over.
When life is to big to tackle, kick it in the shins.
ID: 7550 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Andrew Admire

Send message
Joined: 23 Mar 05
Posts: 108
Credit: 94,266
RAC: 0
Message 7560 - Posted: 22 Jan 2008, 21:26:15 UTC - in response to Message 7550.  

Hm, the server returns \"<!-- SHTML Wrapper - 500 Server Error -->\".
Perhaps we should just start the mirror from scratch using the guide?



That\'s fine, I will start over.



I created a new mirror called rendering project. It is the same address and I changed the security, but I can\'t get it to work. I am getting a different error. Can you take a look?

Thanks,
When life is to big to tackle, kick it in the shins.
ID: 7560 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Janus
Volunteer moderator
Project administrator
Avatar

Send message
Joined: 16 Jun 04
Posts: 4574
Credit: 2,100,463
RAC: 8
Message 7577 - Posted: 24 Jan 2008, 16:44:55 UTC
Last modified: 24 Jan 2008, 16:45:03 UTC

I\'m not sure the server is correctly set up for PHP execution. Could you test it by uploading this small PHP script to a .php and running it through your webbrowser?


If it works it should display a big page with loads of information. If it doesn\'t nothing will happen or an error will be shown.
ID: 7577 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Andrew Admire

Send message
Joined: 23 Mar 05
Posts: 108
Credit: 94,266
RAC: 0
Message 7582 - Posted: 25 Jan 2008, 18:20:32 UTC - in response to Message 7577.  

I\'m not sure the server is correctly set up for PHP execution. Could you test it by uploading this small PHP script to a .php and running it through your webbrowser?

<?php php_info(); ?>

If it works it should display a big page with loads of information. If it doesn\'t nothing will happen or an error will be shown.


This is the error I get

Fatal error: Call to undefined function php_info()
When life is to big to tackle, kick it in the shins.
ID: 7582 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Janus
Volunteer moderator
Project administrator
Avatar

Send message
Joined: 16 Jun 04
Posts: 4574
Credit: 2,100,463
RAC: 8
Message 7584 - Posted: 25 Jan 2008, 21:38:12 UTC

Oh, my bad, it is \"phpinfo()\" and not \"php_info()\".
ID: 7584 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Andrew Admire

Send message
Joined: 23 Mar 05
Posts: 108
Credit: 94,266
RAC: 0
Message 7589 - Posted: 26 Jan 2008, 15:28:25 UTC - in response to Message 7584.  
Last modified: 26 Jan 2008, 15:28:33 UTC

Oh, my bad, it is \"phpinfo()\" and not \"php_info()\".


No prob, it returned lots of data. I guess it works with 755 permission.
When life is to big to tackle, kick it in the shins.
ID: 7589 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Janus
Volunteer moderator
Project administrator
Avatar

Send message
Joined: 16 Jun 04
Posts: 4574
Credit: 2,100,463
RAC: 8
Message 7591 - Posted: 26 Jan 2008, 18:44:58 UTC - in response to Message 7589.  

Oh, my bad, it is \"phpinfo()\" and not \"php_info()\".


No prob, it returned lots of data. I guess it works with 755 permission.

Hm... ok - then PHP is working alright. I wonder what is generating the problems then. Do you have access to the server error-logs?
ID: 7591 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Andrew Admire

Send message
Joined: 23 Mar 05
Posts: 108
Credit: 94,266
RAC: 0
Message 7599 - Posted: 27 Jan 2008, 5:46:20 UTC - in response to Message 7591.  

Oh, my bad, it is \"phpinfo()\" and not \"php_info()\".


No prob, it returned lots of data. I guess it works with 755 permission.

Hm... ok - then PHP is working alright. I wonder what is generating the problems then. Do you have access to the server error-logs?


This is the only thing I saw that had anything to do with BURP

/home/schaadan/public_html/renderingproject.com/burp_mirror/logs/error_log: 1201374437 No footer file installed at standard location. This may be ok. 1201388111 No footer file installed at standard location. This may be ok.
When life is to big to tackle, kick it in the shins.
ID: 7599 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Janus
Volunteer moderator
Project administrator
Avatar

Send message
Joined: 16 Jun 04
Posts: 4574
Credit: 2,100,463
RAC: 8
Message 7605 - Posted: 27 Jan 2008, 9:17:38 UTC - in response to Message 7599.  

Nothing in /var/log/apache2/error*?

A google shows that this may be a file permission issue if using Bluehost/HostMonster - are you using any of these?
ID: 7605 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Andrew Admire

Send message
Joined: 23 Mar 05
Posts: 108
Credit: 94,266
RAC: 0
Message 7609 - Posted: 27 Jan 2008, 14:28:05 UTC - in response to Message 7605.  

Nothing in /var/log/apache2/error*?

A google shows that this may be a file permission issue if using Bluehost/HostMonster - are you using any of these?



I am using bluehost. Bluehost only allows up to 755.
When life is to big to tackle, kick it in the shins.
ID: 7609 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Janus
Volunteer moderator
Project administrator
Avatar

Send message
Joined: 16 Jun 04
Posts: 4574
Credit: 2,100,463
RAC: 8
Message 7610 - Posted: 27 Jan 2008, 14:56:58 UTC - in response to Message 7609.  

Try checking all the file permissions then
ID: 7610 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Andrew Admire

Send message
Joined: 23 Mar 05
Posts: 108
Credit: 94,266
RAC: 0
Message 7613 - Posted: 28 Jan 2008, 13:29:45 UTC - in response to Message 7610.  

Try checking all the file permissions then


I just reset all of the permissions to 755.
When life is to big to tackle, kick it in the shins.
ID: 7613 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Janus
Volunteer moderator
Project administrator
Avatar

Send message
Joined: 16 Jun 04
Posts: 4574
Credit: 2,100,463
RAC: 8
Message 7615 - Posted: 28 Jan 2008, 16:00:59 UTC - in response to Message 7613.  

I just reset all of the permissions to 755.

Great, it seems to be working now - now we only need the crypto keys to match. You can get a new (working) set of keys by going through the mirror setup yet another time.

I\'m sorry that it has to be this hard to set up the mirror software, it is slightly delicate...
ID: 7615 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Andrew Admire

Send message
Joined: 23 Mar 05
Posts: 108
Credit: 94,266
RAC: 0
Message 7617 - Posted: 28 Jan 2008, 19:40:25 UTC - in response to Message 7615.  

I just reset all of the permissions to 755.

Great, it seems to be working now - now we only need the crypto keys to match. You can get a new (working) set of keys by going through the mirror setup yet another time.

I\'m sorry that it has to be this hard to set up the mirror software, it is slightly delicate...


No problem, them more bugs we fix the better. Here is what I get when I try to run the setup process again.

Unable to handle request
The content found at the URL (http://renderingproject.com/burp_mirror/mirror.php) does not seem to match that of a BURP mirror in the setup phase, please inspect and correct it. You may need to delete your mirror configuration file if you have already created such a file.
This is the data that your mirrror returned:

HTTP/1.1 200 OK Date: Mon, 28 Jan 2008 19:40:08 GMT Server: Apache/2.2.6 (Unix) mod_ssl/2.2.6 OpenSSL/0.9.8g DAV/2 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 X-Powered-By: PHP/5.2.5 Connection: close Content-Type: text/html <html><!-- Initial setup --><table class=\"main\"><tr><th>Type</th><th>File/Directory</th><th>Size</th><th>MD5</th></tr><tr><td>[DIR]</td><td><a href=\"?dir=/\">/</a></td><td/><td/></tr><tr class=\"file\"><td></td><td><a href=\"?getid=-1\">header.html</a></td><td>1024</td><td>97f1a8bf15f66d96ddb176904f0bd272</td></tr></table><p class=\"mirror_text\">Please visit the main server (<a href=\"http://burp.boinc.dk/mirror/\">http://burp.boinc.dk/mirror/</a>) for more information about the files contained on this mirror.</p>
When life is to big to tackle, kick it in the shins.
ID: 7617 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Janus
Volunteer moderator
Project administrator
Avatar

Send message
Joined: 16 Jun 04
Posts: 4574
Credit: 2,100,463
RAC: 8
Message 7625 - Posted: 28 Jan 2008, 20:15:42 UTC
Last modified: 28 Jan 2008, 20:16:10 UTC

Ok, try again - for some reason the test failed to find your mirror to be in the correct condition while it was clearly responding with the correct response.
ID: 7625 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Andrew Admire

Send message
Joined: 23 Mar 05
Posts: 108
Credit: 94,266
RAC: 0
Message 7633 - Posted: 29 Jan 2008, 11:54:40 UTC - in response to Message 7625.  

Ok, try again - for some reason the test failed to find your mirror to be in the correct condition while it was clearly responding with the correct response.


Here is the latest error message.

Unable to handle request
Your mirror does not seem to work correctly.
Your mirror is not configured with the set of keys that the server expected. Please go back and redownload new key file(s) to the mirror, replacing the old one(s).
Alternatively the clock on the mirror server does not match the one on the master server closely enough (timezones are of course considered). It must be within 15 mins sync when converting to GMT.
The data that your mirror returned was:

HTTP/1.1 200 OK Date: Tue, 29 Jan 2008 11:53:37 GMT Server: Apache/2.2.6 (Unix) mod_ssl/2.2.6 OpenSSL/0.9.8g DAV/2 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 X-Powered-By: PHP/5.2.5 Connection: close Content-Type: text/html <br>91mmVX+T6VwmB766/2giH/i1+mmd8jAT5q88Dx601u<br>EBeLgD6heb1Gm1FE16noD1iM5KMoFkBiA3F1rxKCM8mis
When life is to big to tackle, kick it in the shins.
ID: 7633 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
1 · 2 · Next

Message boards : Server backend and mirrors : Gandalf the White Returns